PDFlib

高度なPDFアプリケーションの開発を支援する定番プログラムライブラリー Supported by インフォテック株式会社

PDFlib 9 ダウンロード

PDFlib 9 は旧バージョンです。これから PDFlib を使用する場合は PDFlib 10 をご利用ください。

PDFlib 9 / PDFlib+PDI 9 / PPS 9

PDFlib / PDFlib+PDI / PDFlib Personalization Server (PPS)
プラットフォーム ダウンロードファイル
Windows
Windows Server x86 (32-bit)
Windows 8/10/11 x86 (32-bit)
C,C++ Java Perl PHP *1 Python Ruby
.NET  
Windows Server x64
Windows 8/10/11 x64
C,C++ Java Perl PHP *1 Python Ruby
.NET  
macOS
macOS 10.9 以上 x64 C,C++,
Objective-C
Java Perl PHP *1 Python Ruby
macOS 10.9 以上 Universal
x64/ARM64
C,C++,
Objective-C
Java Perl PHP *1 Python Ruby
.NET Core ユニバーサルパッケージ
Windows x64
Linux x64
Alpine Linux x64
macOS x64
.NET Coreでサポートされるすべての言語
Linux
Linux x86 (32-bit) C,C++ Java Perl   Python Ruby
Linux x64 C,C++ Java Perl PHP *1 Python Ruby
Alpine Linux x64 C,C++ Java Perl PHP *1 Python Ruby
Linux ARM64 C,C++ Java Perl PHP *1 Python Ruby
Linux on IBM Z IBM System i・IBM Z をご覧下さい
FreeBSD 12 x64 C,C++ Java Perl PHP *1 Python Ruby
IBM
IBM AIX 7.1 以上 32-bit C,C++ Java Perl  
IBM AIX 7.1 以上 64-bit C,C++ Java  
iOS / Android
iOS 64-bit Objective-C,
C,C++
Android 32-bit/64-bit Java
IBM System i・IBM Z
IBM System i 7.2 以上 C,C++ *3 Java *2 RPG *3  
IBM Z USS 64-bit C,C++ Java  
IBM Z MVS C *3  
Linux-S390x 64-bit C,C++ Java  
*1 PDFlib-in-PHP-HowTo(英語) に詳細がございます。
*2 IBM System i では、Java、PHP に対応した AIX バイナリをお使いいただけます。詳細は「Deploying AIX Binaries on IBM System i with PASE」(英語)をご覧ください。
*3 まもなく PDFlib 9.4.0 がリリースされます。

PDFlib 9.4.0 は下記の言語バージョンをサポートしています。プラットフォームによってサポートされているバージョンが異なる場合があります。該当プラットフォームのパッケージをダウンロードしてご確認ください。

  • PHP 7.4、8.0、8.1 をサポートしています。PDFlib-in-PHP-HowTo (英語) もご確認ください。
    なお、旧バージョンの PDFlib (Windows Server、Linux 向け)については、PDFlib 製品と PHP バージョンの対応表をご覧ください。
  • Perl 5.26、5.28、5.30、5.32、5.34 をサポートしています。
  • Python 3.3、以上をサポートしています。
  • Ruby 2.5、2.6、2.7、3.0、3.1 をサポートしています。
*** 上記パッケージには日本語マニュアルは含まれておりません。
日本語マニュアルからダウンロードしてください。 ***
上記以外のプラットフォーム (OS) 対応版については、別途お問い合わせください。

ブロックプラグイン

PPS 9 で使用する PDFlib ブロックを作成するための Acrobat プラグインです。

Acrobat DC を Continuous (連続トラック) で使用されている場合、2017/11 の Acrobat DC のアップデートにより、ブロックプラグイン 5.11p1 より前のバージョンは動作しなくなりました。下記の最新バージョンをお使いいただけますようお願いいたします。

PDFlib ブロックプラグイン
プラットフォーム ダウンロードファイル
Windows
Acrobat X/XI
Acrobat Standard、Pro 2017/2020
Acrobat Pro DC (32-bit)
ブロックプラグイン 5.40
Acrobat Pro DC (64-bit) ブロックプラグイン 5.40
macOS
Acrobat Standard and Pro 2017/2020 (Intel)
Acrobat DC (universal Intel/M1)
ブロックプラグイン 5.40
Adobe Acrobat X/XI (非推奨) ブロックプラグイン 5.12 (旧バージョン)

新バージョンのブロックプラグインをインストールする前に、旧バージョンのブロックプラグインをアンインストールしてください。

ブロックプラグインは下記の Acrobat バージョンでご利用いただけます。

  • Windows: Acrobat X/XI/DC Acrobat Standard、Pro 2017/2020、Pro DC (32-bit and 64-bit)
  • macOS: Acrobat Standard、Pro 2017/2020、Acrobat Pro DC

ブロックプラグインは、Acrobat Elements や Adobe Reader では動作しません。

マニュアルについては、インストール先のフォルダをご覧いただくか、日本語マニュアルからダウンロードしてください。

日本語マニュアル

各製品のチュートリアルおよび API リファレンスの日本語版です。

PDFlib
ブロックプラグイン
pCOS
(Aug 5, 2022 - )
  • PDFlib トップページ
  • お問合せ
  • 技術情報